use strict;
my $str = '$$ f\'(x) = 12x^2 + 4x $$ $$ f\'(x) = 12x+2x-12 $$ $$ f\'(x) = 12x^3 +4x^2 $$';
my $regex = qr/\$\$((?:(?!\$\$).)*)\$\$/p;
my $subst = '\\\\($1\\\\)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";