using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\$((?:(?!\$\$).)*)\$\$";
string substitution = @"\\($1\\)";
string input = @"$$ f'(x) = 12x^2 + 4x $$ $$ f'(x) = 12x+2x-12 $$ $$ f'(x) = 12x^3 +4x^2 $$";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}