$re = '/\$\$((?:(?!\$\$).)*)\$\$/';
$str = '$$ f\'(x) = 12x^2 + 4x $$ $$ f\'(x) = 12x+2x-12 $$ $$ f\'(x) = 12x^3 +4x^2 $$';
$subst = "\\($1\\)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;