const regex = /\$\$((?:(?!\$\$).)*)\$\$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\$((?:(?!\\$\\$).)*)\\$\\$', 'g')
const str = `\$\$ f'(x) = 12x^2 + 4x \$\$ \$\$ f'(x) = 12x+2x-12 \$\$ \$\$ f'(x) = 12x^3 +4x^2 \$\$`;
const subst = `\\($1\\)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);