using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:```(?:[^`](?!\n\n))+?```|`(?:[^`](?!\n\n))+?`)";
string input = @"Here we are going to be looking for `single-line inline code` and ```Code```
This `is code
test`
This `is not code
test`
```This is code
| variable | required |
|:-----------|:--------:|
| email | yes |
| first_name | yes |
| last_name | yes |
| website | no |
```
```This is not code
| variable | required |
|:-----------|:--------:|
| email | yes |
| first_name | yes |
| last_name | yes |
| website | no |
```
```Code
| variable | required |
|:-----------|:--------:|
| first_name | no |
| last_name | no |
| website | no |
```
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}