$re = '/(?:```(?:[^`](?!\n\n))+?```|`(?:[^`](?!\n\n))+?`)/m';
$str = 'Here we are going to be looking for `single-line inline code` and ```Code```
This `is code
test`
This `is not code
test`
```This is code
| variable | required |
|:-----------|:--------:|
| email | yes |
| first_name | yes |
| last_name | yes |
| website | no |
```
```This is not code
| variable | required |
|:-----------|:--------:|
| email | yes |
| first_name | yes |
| last_name | yes |
| website | no |
```
```Code
| variable | required |
|:-----------|:--------:|
| first_name | no |
| last_name | no |
| website | no |
```
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);