import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td class=\"character\">.*?(?:<a.*?>)?(.*?)(?:</a>)?.*?</td>";
final String string = "<td class=\"character\">\n"
+ " <a href=\"\"> John Doe </a>\n"
+ " \n"
+ " </td>\n"
+ "<td class=\"character\">\n"
+ " \n"
+ " </td>\n"
+ "<td class=\"character\">\n"
+ " John Doe \n"
+ " \n"
+ " </td>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}