// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?ms)<td class="character">.*?(?:<a.*?>)?(.*?)(?:</a>)?.*?</td>"#).unwrap();
let string = "<td class=\"character\">
<a href=\"\"> John Doe </a>
</td>
<td class=\"character\">
</td>
<td class=\"character\">
John Doe
</td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}