use strict;
my $str = '<td class="character">
<a href=""> John Doe </a>
</td>
<td class="character">
</td>
<td class="character">
John Doe
</td>';
my $regex = qr@<td class="character">.*?(?:<a.*?>)?(.*?)(?:</a>)?.*?</td>@msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}