re = /<td class="character">.*?(?:<a.*?>)?(.*?)(?:<\/a>)?.*?<\/td>/m
str = '<td class="character">
<a href=""> John Doe </a>
</td>
<td class="character">
</td>
<td class="character">
John Doe
</td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end