#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?:\/\/\w*\.?)?(youtube\.com\/|youtu\.be?\/)+(watch\?v=|shorts\/)?+(\w+)"
Local $sString = "https://www.twitter.com/BCCI/status/1391737831379275780?s=20" & @CRLF & _
"https://youtu.be/tjue1wAMAhE" & @CRLF & _
"https://www.youtu.be/tjue1wAMAhE1_123vsf" & @CRLF & _
"https://www.youtu.be/watch?v=tjue1wAMAhE1_123vsf" & @CRLF & _
"https://www.youtube.com/watch?v=mvt0ABanNco&t=1" & @CRLF & _
"https://m.youtube.com/watch?v=mvt0ABanNco&utm=1213" & @CRLF & _
"https://youtube.com/shorts/TxeEzZvVGUc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")