package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https?:\/\/\w*\.?)?(youtube\.com\/|youtu\.be?\/)+(watch\?v=|shorts\/)?+(\w+)`)
var str = `https://www.twitter.com/BCCI/status/1391737831379275780?s=20
https://youtu.be/tjue1wAMAhE
https://www.youtu.be/tjue1wAMAhE1_123vsf
https://www.youtu.be/watch?v=tjue1wAMAhE1_123vsf
https://www.youtube.com/watch?v=mvt0ABanNco&t=1
https://m.youtube.com/watch?v=mvt0ABanNco&utm=1213
https://youtube.com/shorts/TxeEzZvVGUc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}