using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https?:\/\/\w*\.?)?(youtube\.com\/|youtu\.be?\/)+(watch\?v=|shorts\/)?+(\w+)";
string input = @"https://www.twitter.com/BCCI/status/1391737831379275780?s=20
https://youtu.be/tjue1wAMAhE
https://www.youtu.be/tjue1wAMAhE1_123vsf
https://www.youtu.be/watch?v=tjue1wAMAhE1_123vsf
https://www.youtube.com/watch?v=mvt0ABanNco&t=1
https://m.youtube.com/watch?v=mvt0ABanNco&utm=1213
https://youtube.com/shorts/TxeEzZvVGUc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}