use strict;
my $str = 'https://www.twitter.com/BCCI/status/1391737831379275780?s=20
https://youtu.be/tjue1wAMAhE
https://www.youtu.be/tjue1wAMAhE1_123vsf
https://www.youtu.be/watch?v=tjue1wAMAhE1_123vsf
https://www.youtube.com/watch?v=mvt0ABanNco&t=1
https://m.youtube.com/watch?v=mvt0ABanNco&utm=1213
https://youtube.com/shorts/TxeEzZvVGUc';
my $regex = qr/^(?:https?:\/\/\w*\.?)?(youtube\.com\/|youtu\.be?\/)+(watch\?v=|shorts\/)?+(\w+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}