$re = '/^(?:https?:\/\/\w*\.?)?(youtube\.com\/|youtu\.be?\/)+(watch\?v=|shorts\/)?+(\w+)/m';
$str = 'https://www.twitter.com/BCCI/status/1391737831379275780?s=20
https://youtu.be/tjue1wAMAhE
https://www.youtu.be/tjue1wAMAhE1_123vsf
https://www.youtu.be/watch?v=tjue1wAMAhE1_123vsf
https://www.youtube.com/watch?v=mvt0ABanNco&t=1
https://m.youtube.com/watch?v=mvt0ABanNco&utm=1213
https://youtube.com/shorts/TxeEzZvVGUc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);