const regex = /^(?:https?:\/\/\w*\.?)?(youtube\.com\/|youtu\.be?\/)+(watch\?v=|shorts\/)?+(\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:\\\/\\\/\\w*\\.?)?(youtube\\.com\\\/|youtu\\.be?\\\/)+(watch\\?v=|shorts\\\/)?+(\\w+)', 'gm')
const str = `https://www.twitter.com/BCCI/status/1391737831379275780?s=20
https://youtu.be/tjue1wAMAhE
https://www.youtu.be/tjue1wAMAhE1_123vsf
https://www.youtu.be/watch?v=tjue1wAMAhE1_123vsf
https://www.youtube.com/watch?v=mvt0ABanNco&t=1
https://m.youtube.com/watch?v=mvt0ABanNco&utm=1213
https://youtube.com/shorts/TxeEzZvVGUc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}