#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-?\d+(\.\d+)?"
Local $sString = "4x²-8x+6 (or 4x^2-8x+6)" & @CRLF & _
"3x-8y=2" & @CRLF & _
"1.2+2x=5" & @CRLF & _
"23y-1=b" & @CRLF & _
"-3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")