// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)-?\d+(\.\d+)?").unwrap();
let string = "4x²-8x+6 (or 4x^2-8x+6)
3x-8y=2
1.2+2x=5
23y-1=b
-3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}