package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-?\d+(\.\d+)?`)
var str = `4x²-8x+6 (or 4x^2-8x+6)
3x-8y=2
1.2+2x=5
23y-1=b
-3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}