import re
regex = re.compile(r"-?\d+(\.\d+)?", flags=re.MULTILINE)
test_str = ("4x²-8x+6 (or 4x^2-8x+6)\n"
"3x-8y=2\n"
"1.2+2x=5\n"
"23y-1=b\n"
"-3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")