const regex = /-?\d+(\.\d+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-?\\d+(\\.\\d+)?', 'gm')
const str = `4x²-8x+6 (or 4x^2-8x+6)
3x-8y=2
1.2+2x=5
23y-1=b
-3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}