# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*[a-z]{2}_[a-z]{2}(\/[^\/]+\.\w+)$//gm;t' <<< "www.company.com/pl_pl/company/contact/thank-you/dl/7011o000003pohk/msp/ttt/doc/whitepapers/pl_pl/whitepaper.pdf"