using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*[a-z]{2}_[a-z]{2}(/[^/]+\.\w+)$";
string substitution = @"";
string input = @"www.company.com/pl_pl/company/contact/thank-you/dl/7011o000003pohk/msp/ttt/doc/whitepapers/pl_pl/whitepaper.pdf";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}