$re = '`^.*[a-z]{2}_[a-z]{2}(/[^/]+\.\w+)$`m';
$str = 'www.company.com/pl_pl/company/contact/thank-you/dl/7011o000003pohk/msp/ttt/doc/whitepapers/pl_pl/whitepaper.pdf';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;