import re
regex = re.compile(r"^.*[a-z]{2}_[a-z]{2}(/[^/]+\.\w+)$", flags=re.MULTILINE)
test_str = "www.company.com/pl_pl/company/contact/thank-you/dl/7011o000003pohk/msp/ttt/doc/whitepapers/pl_pl/whitepaper.pdf"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)