#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Country.{1,30}\().*(?=\))"
Local $sString = "Country: Pakistan (PK)" & @CRLF & _
"Country: Россия-матушка (RM)" & @CRLF & _
"Country: Заграничье бусурманское (ZB)" & @CRLF & _
"" & @CRLF & _
"untry: Pakistan (PK)" & @CRLF & _
"Coutry: Россия-матушка (RM)" & @CRLF & _
"Country: Заграничье бусурманское (ZB)" & @CRLF & _
"" & @CRLF & _
"Coutry: Россия-матушка (RM)" & @CRLF & _
"Country: Заанское (ZB)" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")