using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Country.{1,30}\().*(?=\))";
string input = @"Country: Pakistan (PK)
Country: Россия-матушка (RM)
Country: Заграничье бусурманское (ZB)
untry: Pakistan (PK)
Coutry: Россия-матушка (RM)
Country: Заграничье бусурманское (ZB)
Coutry: Россия-матушка (RM)
Country: Заанское (ZB)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}