import Foundation
let pattern = #"(?<=Country.{1,30}\().*(?=\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Country: Pakistan (PK)
Country: Россия-матушка (RM)
Country: Заграничье бусурманское (ZB)
untry: Pakistan (PK)
Coutry: Россия-матушка (RM)
Country: Заграничье бусурманское (ZB)
Coutry: Россия-матушка (RM)
Country: Заанское (ZB)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)