const regex = /(?<=Country.{1,30}\().*(?=\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Country.{1,30}\\().*(?=\\))', 'gm')
const str = `Country: Pakistan (PK)
Country: Россия-матушка (RM)
Country: Заграничье бусурманское (ZB)
untry: Pakistan (PK)
Coutry: Россия-матушка (RM)
Country: Заграничье бусурманское (ZB)
Coutry: Россия-матушка (RM)
Country: Заанское (ZB)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}