import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Country.{1,30}\\().*(?=\\))";
final String string = "Country: Pakistan (PK)\n"
+ "Country: Россия-матушка (RM)\n"
+ "Country: Заграничье бусурманское (ZB)\n\n"
+ "untry: Pakistan (PK)\n"
+ "Coutry: Россия-матушка (RM)\n"
+ "Country: Заграничье бусурманское (ZB)\n\n"
+ "Coutry: Россия-матушка (RM)\n"
+ "Country: Заанское (ZB)\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}