#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[ ]?(?:1?\d(?:[\.\,]\d{1,2})?|20(?:[\.\,]0?0?)?)[ ]?$"
Local $sString = "sat" & @CRLF & _
"&é12dd" & @CRLF & _
"0" & @CRLF & _
"0.1 " & @CRLF & _
"0.12" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"4 " & @CRLF & _
" 5" & @CRLF & _
"5 " & @CRLF & _
"1.1 " & @CRLF & _
"2.24 " & @CRLF & _
"3.234 " & @CRLF & _
"5,1 " & @CRLF & _
"2,50 " & @CRLF & _
"3,535 " & @CRLF & _
"19" & @CRLF & _
"20" & @CRLF & _
"20.10" & @CRLF & _
"20.02" & @CRLF & _
"20.2" & @CRLF & _
"20.0 " & @CRLF & _
"20.00 " & @CRLF & _
"20.1 " & @CRLF & _
"20.0 " & @CRLF & _
"20,0" & @CRLF & _
"20.02" & @CRLF & _
"20,10" & @CRLF & _
"5.N " & @CRLF & _
"5,e"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")