using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[ ]?(?:1?\d(?:[\.\,]\d{1,2})?|20(?:[\.\,]0?0?)?)[ ]?$";
string input = @"sat
&é12dd
0
0.1
0.12
1
2
3
4
5
5
1.1
2.24
3.234
5,1
2,50
3,535
19
20
20.10
20.02
20.2
20.0
20.00
20.1
20.0
20,0
20.02
20,10
5.N
5,e";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}