use strict;
my $str = 'sat
&é12dd
0
0.1
0.12
1
2
3
4
5
5
1.1
2.24
3.234
5,1
2,50
3,535
19
20
20.10
20.02
20.2
20.0
20.00
20.1
20.0
20,0
20.02
20,10
5.N
5,e';
my $regex = qr/^[ ]?(?:1?\d(?:[\.\,]\d{1,2})?|20(?:[\.\,]0?0?)?)[ ]?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}