// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[ ]?(?:1?\d(?:[\.\,]\d{1,2})?|20(?:[\.\,]0?0?)?)[ ]?$").unwrap();
let string = "sat
&é12dd
0
0.1
0.12
1
2
3
4
5
5
1.1
2.24
3.234
5,1
2,50
3,535
19
20
20.10
20.02
20.2
20.0
20.00
20.1
20.0
20,0
20.02
20,10
5.N
5,e";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}