import re
regex = re.compile(r"^[ ]?(?:1?\d(?:[\.\,]\d{1,2})?|20(?:[\.\,]0?0?)?)[ ]?$", flags=re.MULTILINE)
test_str = ("sat\n"
"&é12dd\n"
"0\n"
"0.1 \n"
"0.12\n"
"1\n"
"2\n"
"3\n"
"4 \n"
" 5\n"
"5 \n"
"1.1 \n"
"2.24 \n"
"3.234 \n"
"5,1 \n"
"2,50 \n"
"3,535 \n"
"19\n"
"20\n"
"20.10\n"
"20.02\n"
"20.2\n"
"20.0 \n"
"20.00 \n"
"20.1 \n"
"20.0 \n"
"20,0\n"
"20.02\n"
"20,10\n"
"5.N \n"
"5,e")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")