# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)GBP([\W\d])/£\1/gm;t' <<< "GBP 5 Off when you spend GBP75.00"