const regex = new RegExp('(?<!\\S)GBP([\\W\\d])', 'gm')
const str = `GBP 5 Off when you spend GBP75.00`;
const subst = `£\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);