$re = '/(?<!\S)GBP([\W\d])/m';
$str = 'GBP 5 Off when you spend GBP75.00';
$subst = "£\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;