import Foundation
let pattern = #"(?<!\S)GBP([\W\d])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"GBP 5 Off when you spend GBP75.00"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"£\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)