use strict;
my $str = 'GBP 5 Off when you spend GBP75.00';
my $regex = qr/(?<!\S)GBP([\W\d])/mp;
my $subst = '£\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";