re = /(?<!\S)GBP([\W\d])/m
str = 'GBP 5 Off when you spend GBP75.00'
subst = '£\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result