#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<!\])<http(s)?:\/\/([^[\]]+?)>(?!\])"
Local $sString = "xxx" & @CRLF & _
"2. 使用`Jetbrains Mono`<https://github.com/JetBrains/JetBrainsMono>等宽字体进行代码高亮" & @CRLF & _
"2. 使用`Jetbrains https://github.com/JetBrains/JetBrainsMono等宽字体进行代码高亮" & @CRLF & _
"代码是开放的,自取:<https://github.com/ttys3/hugo-theme-terminal/tree/ttys3>" & @CRLF & _
"xxxx"
Local $sSubst = "http\$1://\$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)