use strict;
my $str = 'xxx
2. 使用`Jetbrains Mono`<https://github.com/JetBrains/JetBrainsMono>等宽字体进行代码高亮
2. 使用`Jetbrains https://github.com/JetBrains/JetBrainsMono等宽字体进行代码高亮
代码是开放的,自取:<https://github.com/ttys3/hugo-theme-terminal/tree/ttys3>
xxxx';
my $regex = qr/(?<!\])<http(s)?:\/\/([^[\]]+?)>(?!\])/p;
my $subst = 'http\\$1://\\$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";