# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\])<http(s)?:\/\/([^[\]]+?)>(?!\])"
test_str = ("xxx\n"
"2. 使用`Jetbrains Mono`<https://github.com/JetBrains/JetBrainsMono>等宽字体进行代码高亮\n"
"2. 使用`Jetbrains https://github.com/JetBrains/JetBrainsMono等宽字体进行代码高亮\n"
"代码是开放的,自取:<https://github.com/ttys3/hugo-theme-terminal/tree/ttys3>\n"
"xxxx")
subst = "http\\$1://\\$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.