#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)Wetter\ Versuchsflächen\ A.+Niederschlag:\ (.*?)\ mm.+"
Local $sString = "Wetter Versuchsflächen A</a><br/>2021-08-30 09:50:00+02<br/>" & @CRLF & _
"Luftdruck (356m): 969.9 hPa<br />" & @CRLF & _
"Lufttemperatur: 14.3 °C<br />" & @CRLF & _
"Niederschlag: 12.9 mm/24h<br />" & @CRLF & _
"Sonnenschein: 2 h/d<br />" & @CRLF & _
"Wind (Höhe 17m): 6.2 km/h<br />" & @CRLF & _
"Wind (Max.): 14.0 km/h<br />" & @CRLF & _
"Windrichtung: NW <br />" & @CRLF & _
"</p><hr><h4>Aktuelles</h4>" & @CRLF & _
"<p>08.07.2021<br/>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")