// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)Wetter\ Versuchsflächen\ A.+Niederschlag:\ (.*?)\ mm.+").unwrap();
let string = "Wetter Versuchsflächen A</a><br/>2021-08-30 09:50:00+02<br/>
Luftdruck (356m): 969.9 hPa<br />
Lufttemperatur: 14.3 °C<br />
Niederschlag: 12.9 mm/24h<br />
Sonnenschein: 2 h/d<br />
Wind (Höhe 17m): 6.2 km/h<br />
Wind (Max.): 14.0 km/h<br />
Windrichtung: NW <br />
</p><hr><h4>Aktuelles</h4>
<p>08.07.2021<br/>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}