use strict;
my $str = 'Wetter Versuchsflächen A</a><br/>2021-08-30 09:50:00+02<br/>
Luftdruck (356m): 969.9 hPa<br />
Lufttemperatur: 14.3 °C<br />
Niederschlag: 12.9 mm/24h<br />
Sonnenschein: 2 h/d<br />
Wind (Höhe 17m): 6.2 km/h<br />
Wind (Max.): 14.0 km/h<br />
Windrichtung: NW <br />
</p><hr><h4>Aktuelles</h4>
<p>08.07.2021<br/>';
my $regex = qr/Wetter\ Versuchsflächen\ A.+Niederschlag:\ (.*?)\ mm.+/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}