using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Wetter\ Versuchsflächen\ A.+Niederschlag:\ (.*?)\ mm.+";
string input = @"Wetter Versuchsflächen A</a><br/>2021-08-30 09:50:00+02<br/>
Luftdruck (356m): 969.9 hPa<br />
Lufttemperatur: 14.3 °C<br />
Niederschlag: 12.9 mm/24h<br />
Sonnenschein: 2 h/d<br />
Wind (Höhe 17m): 6.2 km/h<br />
Wind (Max.): 14.0 km/h<br />
Windrichtung: NW <br />
</p><hr><h4>Aktuelles</h4>
<p>08.07.2021<br/>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}