$re = '/Wetter\ Versuchsflächen\ A.+Niederschlag:\ (.*?)\ mm.+/ms';
$str = 'Wetter Versuchsflächen A</a><br/>2021-08-30 09:50:00+02<br/>
Luftdruck (356m): 969.9 hPa<br />
Lufttemperatur: 14.3 °C<br />
Niederschlag: 12.9 mm/24h<br />
Sonnenschein: 2 h/d<br />
Wind (Höhe 17m): 6.2 km/h<br />
Wind (Max.): 14.0 km/h<br />
Windrichtung: NW <br />
</p><hr><h4>Aktuelles</h4>
<p>08.07.2021<br/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);