import Foundation
let pattern = #"Wetter\ Versuchsflächen\ A.+Niederschlag:\ (.*?)\ mm.+"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
Wetter Versuchsflächen A</a><br/>2021-08-30 09:50:00+02<br/>
Luftdruck (356m): 969.9 hPa<br />
Lufttemperatur: 14.3 °C<br />
Niederschlag: 12.9 mm/24h<br />
Sonnenschein: 2 h/d<br />
Wind (Höhe 17m): 6.2 km/h<br />
Wind (Max.): 14.0 km/h<br />
Windrichtung: NW <br />
</p><hr><h4>Aktuelles</h4>
<p>08.07.2021<br/>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)